Downgrade eines Paketes

Es gibt Fälle, wo ein Downgrade eines Paketes auf eine ältere Version sinnvoll sein könnte. Mir ist es passiert, daß nach einem Pacman-Update auf Version 6.0.0.2 das Pamac Paket aus dem AUR inkompatibel wurde und sich nicht mehr aufrufen ließ. Durch ein Downgrade konnte ich Pamac jedoch wieder nutzen. Diese Lösung ist temporär und provisorisch, bis dieses Problem hoffentlich zeitnah gelöst sein wird.

Auf https://archive.archlinux.org sind alle offiziellen Pakete aufgelistet. Mit folgender Befehlszeile stufe ich hier auf eine ältere Paket-Version von Pacman 5.2.2.4 zurück:

  sudo pacman -U https://archive.archlinux.org/packages/p/pacman/pacman-5.2.2-4-x86_64.pkg.tar.zst